MaLiLib logo

MaLiLib

Библиотека общего кода для модов Minecraft, включая настройки, GUI и утилиты. Требуется для некоторых модов.

Категории модов


Downloads 8M загрузок
Views 0 просмотров
Created Создано 5 лет назад

Внешние ресурсы

Разработчики мода

masady автар

masady

Описание мода

MaLiLib: библиотека модов для Minecraft


MaLiLib - это библиотечный мод, содержащий общий код для клиентских модов masas. Он содержит все настройки конфигурации, клавиатурные сочетания, большую часть кода GUI и много других утилит для модов, использующих его. Убедитесь, что вы загружаете правильную версию мода с страницы Файлов!


Имейте в виду, что есть версии для Fabric и Forge для MC версий 1.14.4 и выше, обратите внимание на имя файла для получения правильной версии! Например: malilib-fabric-1.15.2-0.10.0-dev.20+arne.6.jar


MaLiLib обязателен для следующих модов, начиная с указанных версий: Item Scroller - 0.14.0 и выше, Litematica - для любых сборок, начиная примерно с 2018-06-11, MiniHUD - 0.17.0 и выше, TellMe - 0.6.1 и выше, Tweakeroo - 0.8.0 и выше. Точная требуемая версия для каждой версии мода будет указана в журнале изменений каждого зависимого мода.


С начала версии 0.10.0-dev.19 в MaLiLib встроена только необходимая часть Fabric API, поэтому вам больше не нужно загружать мод Fabric API отдельно только для моих модов.


Для MC 1.13.x обратите внимание, что поддерживается только 1.13.2, поэтому вам нужно использовать Rift для 1.13.2 от вилки Chocohead. Установка Rift 1.13.2 (если вы играете в Minecraft 1.13.2):



  • Убедитесь, что у вас установлен Java 8 (Java 9 или новее не будет работать с Rift)

  • Опция 1 - Используйте запускатель MultiMC (я лично рекомендую это!):


Скачайте MultiMC с сайта


Загрузите этот zip:


В MultiMC нажмите "Добавить экземпляр" сверху


Выберите "Импортировать из zip" слева и выберите загруженный вами zip-файл


Дайте экземпляру имя сверху и нажмите OK для завершения установки Rift в этот экземпляр


Опция 2 - Установите Rift 1.13.2 в оригинальном запускалке:


Сначала загрузите установщик Rift отсюда: /jitpack-aeee80c1fb-1/Rift-jitpack-aeee80c1fb-1.jar


Закройте запущенный запускальщик Minecraft, если у вас он запущен


Дважды щелкните по jar-файлу Rift, чтобы запустить его


Если установка прошла успешно, затем откройте эквивалентный файлу C:UsersmasaAppDataRoaming.minecraftversions1.13.2-rift-1.0.4-SNAPSHOT1.13.2-rift-1.0.4-SNAPSHOT.json (в зависимости от вашей ОС и имени пользователя и т. д.) в текстовом редакторе


В массиве библиотек, на строке com.github.Chocohead:Rift, замените строку SNAPSHOT на aeee80c1fb-1


Сохраните файл


Готово. Игра теперь должна запускаться с установленным Rift при запуске ее с профилем 1.13.2-rift-1.0.4-SNAPSHOT в оригинальной запускалке.


Если у вас есть вопросы или вам нужна помощь, лучший и быстрый способ получить ответы - это на моем сервере Discord.

Скриншоты мода

Скриншот мода MaLiLib #15680